Jump to content


Suse 10.3


  • Please log in to reply
8 replies to this topic

#1 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 06 December 2007 - 09:38 PM

Ok, I have a Windows XP installation on an IDE 80GB HDD and a load of Suse 10.3 on a 36GB SATA. In the BIOS the 36GB (suse) drive is first and the 80GB (xp) is second, if I switch them around grub boot loader will not load, the current setup allows me to boot into suse where I am now, but Windows fails to load returning an error of:

rootnoverify (hd0,4)
chainloader (/dev/sda1,0)+1

Error 23: Error while parsing number

Press any key to continue...

Now I have made a backup of my menu.lst and am copying it here in hope someone can suggest a solution.

# Modified by YaST2. Last modification on Thu Dec 6 17:15:14 UTC 2007
default 0
timeout 8
gfxmenu (hd0,4)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
root (hd0,4)
kernel /vmlinuz-2.6.22.5-31-default root=/dev/mapper/via_jbgafbid_part7 vga=0x31a resume=/dev/mapper/via_jbgafbid_part6 splash=silent showopts
initrd /initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd1,0)
chainloader (/dev/sda1,0)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,4)
chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
root (hd0,4)
kernel /vmlinuz-2.6.22.5-31-default root=/dev/mapper/via_jbgafbid_part7 vga=normal showopts ide=nodma apm=off acpi=off noresume edd=off 3
initrd /initrd-2.6.22.5-31-default

Hopefully someone can point me in the right direction as I have yet to figure out the proper answer, I did read a great deal in a short time and make some attempts but am starting to worry if I continue then I will end up with neither working.

#2 Linoman

Linoman

    Established Member

  • Sponsor
  • PipPipPipPipPip
  • 1,536 posts
  • Country:South Africa (Cape-Town)

Posted 09 December 2007 - 10:29 AM

Use a Windows 98 setup disk. Use the joys of format/mbr, (aka make sure there is no grub boot loader, cause this will proberly kill xp's to). Then use Windows XP recovery disk, reinstall the bootloader. Then fire up suse using your install disk and reinstall grub.

That should sort everything out

#3 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 09 December 2007 - 03:11 PM

View PostLinoman, on Dec 9 2007, 05:29 AM, said:

Use a Windows 98 setup disk. Use the joys of format/mbr, (aka make sure there is no grub boot loader, cause this will proberly kill xp's to). Then use Windows XP recovery disk, reinstall the bootloader. Then fire up suse using your install disk and reinstall grub.

That should sort everything out

Considered that as I noticed I am not using the windows bootloader, but my problem is in reinstalling grub is that it autodetected and set things up the way they are now, so reinstalling would autosetup just as things are leaving me nowhere. I obviously do not know the proper manual setup and shouldn't have been messing with this on this pc.

#4 Linoman

Linoman

    Established Member

  • Sponsor
  • PipPipPipPipPip
  • 1,536 posts
  • Country:South Africa (Cape-Town)

Posted 09 December 2007 - 07:16 PM

Hmmm, a dilema indeed. Will see if I find out anything for you

#5 brewin

brewin

    Victory is mine!

  • Administrator
  • PipPipPipPipPip
  • 1,261 posts
  • Location:Missouri
  • Interests:Anything interesting.
  • Country:USA

Posted 09 December 2007 - 07:41 PM

View PostTweak, on Dec 6 2007, 04:38 PM, said:

rootnoverify (hd0,4)
chainloader (/dev/sda1,0)+1
It appears Grub is trying to boot Windows from your Suse partition on the first drive (ie. hd0,4).

Assuming Windows is on the first partition of the second drive, you'll want something like this:

title Windows
rootnoverify (hd1,0)
makeactive
chainloader +1

#6 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 10 December 2007 - 03:49 AM

View Postbrewin, on Dec 9 2007, 02:41 PM, said:

It appears Grub is trying to boot Windows from your Suse partition on the first drive (ie. hd0,4).

Assuming Windows is on the first partition of the second drive, you'll want something like this:

title Windows
rootnoverify (hd1,0)
makeactive
chainloader +1



Ah, Brew, one of the people I was hopeful of seeing a reply from....

Sucks, it gives me grub menu and when I select windows it just says

rootnoverify (hd1,0)
makeactive
chainloader +1

then the cursor sits flashing, but windows and other files are still there, I need to get this working and so far nothing works, I have tried around 30 different combinations and refuse to wipe the load as it is a work system I thought would be safe....WRONG!!!

Edited by Tweak, 10 December 2007 - 03:53 AM.


#7 brewin

brewin

    Victory is mine!

  • Administrator
  • PipPipPipPipPip
  • 1,261 posts
  • Location:Missouri
  • Interests:Anything interesting.
  • Country:USA

Posted 10 December 2007 - 07:29 AM

View PostTweak, on Dec 9 2007, 10:49 PM, said:

Ah, Brew, one of the people I was hopeful of seeing a reply from....

Sucks, it gives me grub menu and when I select windows it just says

rootnoverify (hd1,0)
makeactive
chainloader +1

then the cursor sits flashing, but windows and other files are still there, I need to get this working and so far nothing works, I have tried around 30 different combinations and refuse to wipe the load as it is a work system I thought would be safe....WRONG!!!
I'm trying to get my head around what's going on. It's always difficult without actually seeing it. Where did you edit that? Did you change it in menu.lst or did you do it from grub?

If you didn't know, you can edit the boot menu from grub by pressing 'e' on the line you want to edit, then change it and press 'enter' and then 'b' to boot it once you've got all the lines correct. If you do this, then you can instantly see if it works or not and you don't have to boot up, edit menu.lst, then reboot.

#8 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 10 December 2007 - 03:08 PM

View Postbrewin, on Dec 10 2007, 02:29 AM, said:

I'm trying to get my head around what's going on. It's always difficult without actually seeing it. Where did you edit that? Did you change it in menu.lst or did you do it from grub?

If you didn't know, you can edit the boot menu from grub by pressing 'e' on the line you want to edit, then change it and press 'enter' and then 'b' to boot it once you've got all the lines correct. If you do this, then you can instantly see if it works or not and you don't have to boot up, edit menu.lst, then reboot.

I have done it both ways, and I did figure out the press e to edit, but I have also edited the menu.lst from within the OS. I have more information by running /sbin/fdisk -l at a terminal window

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x283f283e

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9729 78148161 7 HPFS/NTFS

Disk /dev/sdb: 37.0 GB, 37019566080 bytes
255 heads, 63 sectors/track, 4500 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000d0046

Device Boot Start End Blocks Id System
/dev/sdb1 1 4500 36146218+ f W95 Ext'd (LBA)
/dev/sdb5 1 9 72229+ 83 Linux
/dev/sdb6 10 271 2104483+ 82 Linux swap / Solaris
/dev/sdb7 272 1989 13799803+ 83 Linux
/dev/sdb8 1990 4500 20169576 83 Linux

Disk /dev/dm-0: 37.0 GB, 37019516928 bytes
255 heads, 63 sectors/track, 4500 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000d0046

Device Boot Start End Blocks Id System
/dev/dm-0p1 1 4500 36146218+ f W95 Ext'd (LBA)
/dev/dm-0p5 1 9 72229+ 83 Linux
/dev/dm-0p6 10 271 2104483+ 82 Linux swap / Solaris
/dev/dm-0p7 272 1989 13799803+ 83 Linux
/dev/dm-0p8 1990 4500 20169576 83 Linux
Warning: invalid flag 0x0000 of partition table 6 will be corrected by w(rite)

Disk /dev/dm-1: 37.0 GB, 37013727744 bytes
255 heads, 63 sectors/track, 4499 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/dm-1p1 1 9 72229+ 83 Linux
/dev/dm-1p2 9 271 2104515 5 Extended
/dev/dm-1p5 10 271 2104483+ 82 Linux swap / Solaris
/dev/dm-1p6 ? 25463 50649 202309635+ 7 HPFS/NTFS

Disk /dev/dm-2: 73 MB, 73963008 bytes
255 heads, 63 sectors/track, 8 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-2 doesn't contain a valid partition table

Disk /dev/dm-3: 2154 MB, 2154991104 bytes
255 heads, 63 sectors/track, 261 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-3 doesn't contain a valid partition table

Disk /dev/dm-4: 14.1 GB, 14130998784 bytes
255 heads, 63 sectors/track, 1717 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-4 doesn't contain a valid partition table

Disk /dev/dm-5: 20.6 GB, 20653645824 bytes
255 heads, 63 sectors/track, 2510 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-5 doesn't contain a valid partition table

#9 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 11 December 2007 - 01:48 AM

Well I got an answer and tried it and it worked...simple swap of lines, somehow the order was wrong.

title Windows XP Professional
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

That solved the issues, once that worked I switched XP to being the topmost listed choice and set it to default, thanks again for the help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users