Jump to content


BATTLEFIEL 2142 VISTA PROBLEM!


  • Please log in to reply
18 replies to this topic

#1 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 06 September 2007 - 06:32 AM

ok well im running vista

and punkbuster keeps kicking me

ive tried updating it with pbsetup.exe

and ive also run it as administrator...

what else could be the problem?

i can be in-game for about a minute, maybe 2 if im lucky, and then i get kicked

it just comes up with a message "PUNKBUSTER!"

thats it, no reason, nothing.

please i LOVE this game, i need help something cronic!


EDIT: i also might add i cant go into properties and click "run this program as administrator"

but i can right click and go "run as administrator"

anyone please help?

Edited by Linkus5KLz, 06 September 2007 - 06:49 AM.


#2 banj0

banj0

    American Idle

  • Sponsor
  • PipPipPipPipPip
  • 1,520 posts
  • Location:Detroit
  • Country:States

Posted 06 September 2007 - 07:00 AM

could be a java virus. have you updated your PSU drivers?

#3 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 06 September 2007 - 07:02 AM

i only got this computer last week

everything already installed (pc shop did it, i had no choice in the matter)

how would i update my PSU drivers?

#4 banj0

banj0

    American Idle

  • Sponsor
  • PipPipPipPipPip
  • 1,520 posts
  • Location:Detroit
  • Country:States

Posted 06 September 2007 - 07:06 AM

Disable User Access Control (UAC). Control Panel----> User Accounts----> Turn User Account Control On or Off. Turn it off, reboot, and try again.

#5 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 06 September 2007 - 07:11 AM

i had already turned it off earlier this week

and i just turned it on about 10mins ago to see wether being able to click "run as administrator"

and nothing seems to work.

#6 banj0

banj0

    American Idle

  • Sponsor
  • PipPipPipPipPip
  • 1,520 posts
  • Location:Detroit
  • Country:States

Posted 06 September 2007 - 07:24 AM

is your IP addy known by PB as a cheater? I'm not accusing you, but if you're able to start a game and then get kicked, it's prolly 2142 servers autokicking your IP address or a fubar'd cfg file in your EA folder.

I'm on Vista64 and play 2142 on the regular with no problems. Try using a proxy IP address or a DHCP release if your ISP gives you a dynamic address. If you still get problems, then it could be PB being stupid about a beta driver. If so, I'd try a reinstall.

It's not Vista f'ing you up. I'm on Vista and can play 2142 on the regular. It's something else.

Edited by banj0, 06 September 2007 - 07:28 AM.


#7 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 06 September 2007 - 08:14 AM

my IP shouldnt be banned, and if it is someones got the same IP (can anyone say impossible?)

i never hack and havent had a chance to get banned haha

the only other game i have that uses PB is soldier of fortune 2 and ive been a model participant on that.

i know its not my vista, its really annoying though,

and i know its not my BF2142.. well it shouldnt be, i bought it yesterday, from JB-HiFi

#8 m.oreilly

m.oreilly

    rog'er wilco

  • Admin
  • PipPipPipPipPipPip
  • 8,747 posts
  • Country:lower uncton

Posted 07 September 2007 - 05:56 AM

View PostLinkus5KLz, on Sep 6 2007, 01:14 AM, said:

...and if it is someones got the same IP (can anyone say impossible?)
unless it's been "nic"ed... :)

Quote

...i bought it yesterday, from JB-HiFi

isn't that scara's new bidness, down under?

#9 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 07 September 2007 - 06:37 AM

well that was loads of help. haha.

anyone else?

im really desperate to play it aye haha,

#10 m.oreilly

m.oreilly

    rog'er wilco

  • Admin
  • PipPipPipPipPipPip
  • 8,747 posts
  • Country:lower uncton

Posted 07 September 2007 - 07:17 AM

it could be your ip provider, or a driver issue, as banj mentioned :) gosh, a stumper to me (i don't game, atm...).

#11 Tweak

Tweak

    Established Member

  • Members
  • PipPipPipPipPip
  • 674 posts
  • Country:US

Posted 07 September 2007 - 05:42 PM

You should run it in Compatibility Mode as XP, XP SP2, or I even read someone used Vista but since Vista isn't installed anymore I wouldn't know on that one, and also do the Run As Admin, this has worked for others. I also have read that firewalls and antivirus programs can cause issues and that you should make certain the Punk Buster services are all running as they should be before trying to play.

Official statement from PB:
"To run PunkBuster under Windows Vista you will need to run the game as an administrator. To do this, select the original game executable and right click it. Select "Properties", then the "Compatibility" tab. From that tab, check the box labeled "Run this program as an Administrator" and click OK. You need to follow these steps, even when you are logged in as admin, else the game will be started in user mode.

If you use a game launching program, like ASE or XFire, please use the same shortcut as explained above, otherwise the game will not be launched with Administrator privileges resulting in an "Inadequate O/S Privileges" kick."

Maybe these will help, maybe not.

#12 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 08 September 2007 - 04:16 AM

yeah i am running it as admin,
and its not coming up with a O/S priviledge statement
i tried running it as XP SP2 but it wouldnt find the disc for some extremely stupid reason, ill give it another go though, see if itll run properly.

#13 m.oreilly

m.oreilly

    rog'er wilco

  • Admin
  • PipPipPipPipPipPip
  • 8,747 posts
  • Country:lower uncton

Posted 08 September 2007 - 06:58 AM

View PostLinkus5KLz, on Sep 7 2007, 09:16 PM, said:

yeah i am running it as admin,
and its not coming up with a O/S priviledge statement
i tried running it as XP SP2 but it wouldnt find the disc for some extremely stupid reason, ill give it another go though, see if itll run properly.
try turning UAC on, then repeating the steps. there are issues w/ certain apps if UAC is turned off. goofy but true...

#14 Linkus5KLz

Linkus5KLz

    New Member

  • New Members
  • Pip
  • 7 posts
  • Country:Australia

Posted 09 September 2007 - 08:58 AM

ok well yesterday, i decide to try and play again (take in mind i havent done anything except what ive told you above, and after i did those it didnt work)

yeah as i was saying, i decided to go play, and TA-DA! i can play now :/ dont ask me how cause i have NO idea, but ive been playing non-stop for like the past 2 days haha

thanks for all the help you guys! much appreciated

#15 David_Heavey

David_Heavey

    =IBF2= Cofounder

  • Sponsor
  • PipPipPipPipPip
  • 949 posts
  • Location:Ireland
  • Country:Ireland

Posted 09 September 2007 - 12:25 PM

It's not actually a Punkbuster problem. It's a compatibility issue with the 1.25 2142 patch and Vista. I can play no problem on Vista if I use an older version of the game (hard to find servers though). Bring on 1.40 I say.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users