Jump to content

Weird install thing with suse 10.x

  • Please log in to reply
2 replies to this topic

#1 banj0


    American Idle

  • Sponsor
  • PipPipPipPipPip
  • 1,526 posts
  • Location:Detroit
  • Country:States

Posted 28 December 2006 - 06:47 AM

This has been a head scratcher of mine for a while and any thoughts/comments are appreciated. This has happened on suse 10.1, and 10.2. I should mention that everything works fine after the fix I use now, but it's just too weird for me to understand.

After using the gui install on both versions, multiple times, I always get the same problem. I've tried using nothing more than the default software and I've tried using online update during the install.

When the install finishes with either 800x600, 1024x768, 1440x900 (my native res), or 1280x1024 (the Installation default for my box) Suse freezes before X is loaded. I get a totally black screen with a working "X" mouse cursor. Ctrl-Alt-F(x) don't work. Ctrl-backspace doesn't work either. It's just stuck. If I reboot and boot from the HD, I get the same thing.

When I try to test the settings during the hardware config right before the install is finished, I get a warped mess on my monitor. That's with 24bit and 16bit colors and all the resolutions I listed above. Ctrl-Backspace doesn't work and my only recourse is to kill the power to the PSU. But here's the rub: I've found that if I reboot the machine after that crappy mess and then try to boot from the HD (without truly finalizing the installation) the DVD(s) I use for the install throw out a message saying that the "Installation has failed. Would you like to continue? Some settings may need to be re-entered." <----not verbatim but really, really close.

If I choose "yes", I get to fill in my user info and try again with the hardware config and the same problem appears.

When I choose "no", suse goes to init 3 and verbose booting and Voila!! I boot to KDE just fine. After installing the nVidia driver everything is peaches and cream.

This has happened on more installs than you'd believe but this happens everytime. And everytime it has happened, the fix was to test my gcard/monitor settings, let it crap out, kill the power, reboot and choose "no" when I'm asked whether or not to continue the Installation.

I'm not complaining or anything because it works and works well after all this. I just can't logically wrap my head around the "why" of it. Anyone have an idea?

:bluerip: I guess this is prolly a dumb question. :scara: I'm curious though. TIA.


#2 m.oreilly


    rog'er wilco

  • Admin
  • PipPipPipPipPipPip
  • 8,833 posts
  • Country:lower uncton

Posted 28 December 2006 - 07:19 AM

gpu driver issues at initial boot. did you choose the vesa stock default gpu driver option, or...? i had the same thing happen... :scara:

#3 banj0


    American Idle

  • Sponsor
  • PipPipPipPipPip
  • 1,526 posts
  • Location:Detroit
  • Country:States

Posted 28 December 2006 - 08:10 AM

No, I didn't choose any option upon the initial boot. Matter of fact, I didn't even have an initial boot unless you count the initial "boot from DVD" upon the initial install. When Grub loads at startup (either on the failing install I mentioned or on the successful installs), I do have the option of F4 and setting the resolutions to above or Vesa, but if I don't follow the steps above it doesn't work no matter what.

Under hardware config, before booting to anything, the suse hardware config sees my 7800gt and my ViewSonic monitor by name and model, in both cases. I guess I should also mention that also happened on my internet box: sempron64, agp 5200, MSI micro mobo.

But, the majority of installs are on my main box. Spec in siggy below but with a maxtor IDE and my 1 surviving maxtor SATA.

No matter the hardware, I get the same thing. If I let the install finish, no worky. If I "test settings", kill the power, and choose "no" under continue install, it works just fine. Very strange.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users